UI Troubleshooting

Hello and welcome to the UI Troubleshooting page, where I go through common problems with UIs and how you can fix them. Comments are enabled if you have new fresh problems that need solving!


Weakaura Problems

Here are the most common problems with the Weakaura addon that I have been asked.

Problem: Texture Aura Shows up as a Green Square

Description: After importing a texture weakaura, it only shows up as a green square (or other color)!

Green Square of Dooooooom

Solution: The green square is basically weakauras version of 404: File not Found. It tries to load a targa-file to use as a texture, but it can’t find it. This could be due to the file is missing, or the file path or search way is incorrect. To fix it, go into the Display tab and check what file path the texture has.

Make sure that the location the art file and the file path is matching. If they aren’t, either rename the folders/files in the Wow folder, or rename the file path to the correct location. Be sure to check spelling!

If you have moved the art file or renamed it, you need to reboot World of Warcraft to make it reachable again.

Problem: Strange Backdrop on my Icon Weakauras

Description: My Icon Auras have a weird backdrop that I don’t know where it came from!

This problem can present itself with a variety of colors and shapes

Solution: You are likely trying to skin your Icon Auras with two addons at the same time. The most common combination is Masque and Elvui Addonskins. To fix the problem, you need to either disable masque or addonskins, depending on which skin you want to keep. You can disable Addonskins’ effect on Weakauras in the Elvui menu, here:

Problem: I’ve imported weakauras, but can’t see them!

Description: I have weakauras that are fully visible in the Weakaura menu. But when I play, they don’t show up!

Solution: If it concerns imported weakauras, it’s likely not a case of them not working properly. Rather, the reason could be that the aura does not want to load for your character. To confirm this, check if the aura is in the Loaded section in the left column, or the Unloaded section.

If the Aura is Loaded: The problem is likely within the triggers and they have to be adjusted.
If the Aura is NOT Loaded: You need to go into the load tab and check what conditions need to be fulfilled for the aura to load.

Example: Only loads for the Monk class
Example: Only loads when in a flexible raid on Heroic mode

Browse the whole list of load conditions, and correct them to your preference.


Elvui Problems

A list of the most common problems with the addon Elvui that I have been asked.

Problem: Error on Unitframes (Colortags not in the Client!)

Description: There are error tags on my elvui unit frames / I can’t find the Colortags addon!

Solution: You will run into this problem if you are using an Elvui profile that has special addon for tags. You can either download the addon (Absorbtags are on the Tukui Client, and an old version of Colortags can be downloaded here), or you can simply change the tags to a valid one. To see what tags are valid, you need to go to the Elvui menu. If the error is on the Player Frame, check out in the Player Frame menu:

The error can be displayed in the Health / Power text for ANY of the unit frames. Make sure you correct the tag for the correct unit frame. You can also delete the tags in the text field if you do not want any text at all.

Problem: Error when Trying to Import Elvui Profile

Description: I am trying to import an Elvui profile, but it only says error!

Solution: This is 99% of the time due to a small blank-space at the end of the code. It can happen when you copy and paste the code, that it has a blank-space at the end that shouldn’t be there. Simply remove it, and it should work fine.

 

If you have a problem not listed above – make a comment below!



Back to Top

61 thoughts on “UI Troubleshooting”

  1. Hello, I do not understand how to have your ui … I really love your work and I really would love to continue my Monk with your interface. Your site help me a lot since I play Mistweaver and I thank you very much and hope that you continue what you are doing for a long time . Sorry for my english bad enough I am french …

    1. The UI I have is a blend of the addons Elvui (interface, unit frames, etc) and WeakAuras (spell cooldowns, graphic elements). While I don’t have a guide for the Elvui set up (yet), you can import parts of the Weakauras I’ve made. I suggest downloading Elvui and Weakauras and start by getting familiar with them. :)

  2. Yes :) I thought you were going to put the Elvui profile importantly, I play with Elvui Weak and have for years , but your work with executives on investment Elvui attracted me a lot why I asked :) I thank you anyway and continue your work so I support you tremendously .

  3. This is all amazing! I added the Serpent Timers, but I altered them to show the Soothing Mist channel, since I don’t have that trinket. I was having trouble with the green squares, but no matter what I did the pictures were not working! I was going to have my boyfriend help me out and as soon as I showed him, it worked! I did download Masque so maybe that was it. Thank you so much for putting these up here! I am excited to play Mistweaver even more! :)

    1. Hello Gwenny, I’m so happy you liked the new weakauras!
      Custom textures can be a little bit of a hassle to work with, but they’re worth it ^^. Glad it worked out!

      1. I do have an issue though. Whenever I hover over the area that the Serpent Timers are located it keeps bringing up box that says “Right-click to do this” and “Shift+click to do something else” (I don’t know exactly what because I am at work and not actually on WoW at the moment). Sometimes its for the MT1-19 which are not even in that area. Do you know what could cause this? I could provide a screenshot later if you want one.

          1. Saw your description of the problem and was completely “wtf?”, never heard of that before. Glad it solved itself! Rebooting either your computer or just WoW usually solves most texture-related problems. Remember to always reboot if you make any changes to files or file paths as well! ^^

  4. How can I incorporate the mistweaver icon auras with the ui’s you made for windwalker/brewmaster? I saw you’re examples for those two specs having a full set of icons. Is this something that you will add later? Great work :).

    1. I haven’t done a windwalker/brewmaster icon library due to the immense time it takes to create one. Since it’s a Mistweaver blog, I’ve focused on the Mistweavers ones – I only shared the windwalker/brewmaster texture auras because it could be done within a reasonable time.
      And thank you ^^

  5. How do you get your Extend Life and ReM weakauras based off of a group trigger to work? I can’t seem to figure out how to get them to activate properly. They’re not imported in a Dynamic Group, but my weakauras tells me i’m going to have issues with auto-cloning if they’re not in a dynamic group when i tell it to show all matches. ( :( I dunno what that even means)

    1. The ones I’ve shared in the library should only activate once you are in a group (and does not show if you are solo), and they don’t need auto-cloning enabled (which is used when you want to show several icons, instead of showing the number of people affected). Does it not work for you when in a group? If not, try as a first step to re-import the aura!

  6. Nah, the Extend Life and ReM Down aura works, but that’s the only one. I’m thinking i have some setting messed up somewhere because the ReM cooldown timer doesn’t show up even when I have it with the same trigger as a different ReM cd timer in a different weakauras. I will hopefully find the problem when I can get back to it early next week.

  7. is there a way to remove the minimap Zoom in, zoom out buttons?
    can’t seem to find the options for it in General – Minimap

    cause their kinda stuck in top right corner…

    1. Not really sure about this one since I don’t have zoom buttons on my map, and I can’t remember disabling it or anything. But it might be so that you need the Shadow&Light extension, where you get extra settings in /ec Shadow&Light > Settings > Minimap.

      1. found the problem. used an addon called Leatrix plus, with Customise minimap option enabled.
        it will always show the zoom buttons and zone at top right screen, so disabled it and its gone :)

  8. Questions regarding the weak aura’s for all the spells. The weak aura’s are great and work but EVERY single one of them when i import them has a square around it the same color as your overall UI..the monkish green color.

    I tried to troubleshoot it myself before having to ask but i gave up after an hour and a half with no luck.

    Thanks so much!

    1. It means you have Elvui Addonskins skinning your weakauras. Open up the Elvui menu and go to Addonskin and untick weakauras there and reload ui :) (a very common problem, I should add the fix to the page)

  9. Hello mate, great work with everything on the site! I love what I see / read!
    However I have one question regarding your chat weakauras. When I am in Wise Serpent stance my chats work fine with your weakauras (the greenish chat) however when I change stance to crane I dont know how to get the red chat.I have it on my computer in an weakauras folder. But I seem unable to find an option where I can write in the panel texture or what ever when I change stance so the chat’s change color.. If you know what I mean please help me out x) xoxo

    1. Hello!
      Let’s see, if you use the WeakAura I’ve shared on the Custom Aura page, both textures should appear (check the /wa menu to see that they are present, and loaded) – if you use the Elvui texture on chat panels I’m sorry to say that it only allow one texture per profile. Which option do you use?

  10. hi i love the mistweaver ui however my addons arent in a bar just above minimap like yours and i dont know why. How do make them load to the mouseover bar like yours? Thanks

    1. It should be automatically mouseover when importing my Elvui profile, but in case it didn’t work as it should go to /ec > Action bars and go to the the action bar you want to be on mouseover. In the menu, tick in the “Mouseover” box.
      Good luck :)

  11. I have a UI problem… All of my textures are absolutely bright green, nothing else. I tried all of the trouble shooting fixes, but I still haven’t found an answer. I even double checked to make sure I was downloading the right ones, putting them in the right places in folders, and importing correctly. I tried reloading my UI, and rebooting my computer. Either I’m blanking out on something “duh” or I’m doing something wrong. Do you have any advice?

    1. Wow, I had two “OriginalMistweaver” folders in my MistyTeahouse folder. Just had to delete that extra folder! I guess three times a charm, right? Thank you so much for information on creating personal UIs! It helped a ton! <3

      1. An easy thing to miss – I’m glad you got it sorted! ^^
        Thank you for the comment and I hope you enjoy your new UI :D

    2. Mine did the same thing. They were in the right folder according to the directions posted but when I looked in WeakAuras and where they were looking for the art I found that “MistyTeahouse” should actually be “Mistyteahouse.” Once I change the T to a lower case t, the art came up as expected. Hope this helps.

    1. The problem is described in the above section “Texture Aura Shows Up as a Green Square”. The file path is incorrect or the art files have been placed incorrectly, so double-check your spelling and location of the files :)

  12. Simply love the WA’s and theme in general, great work!
    I took some of your WA’s and made them into WW WA’s, so I was wondering what kind of border colour would you use for WW? (Crane = 3e161f, Jade Serpent = 003e38).
    It would really complete my current UI.

    Agian great work, and I hope you keep it up!

    Also, your Chi and CD WA look neat!

    1. Auras that show in the wrong stance are described above under “Auras Do not Show in the Correct Stance” section. If there’s any visual oddities that need fixing, check the “Display” tab.

    1. The custom textures are part of an old project that I used when Mistweavers had Serpent/Crane stance, so that might be the problem. Try changing the trigger to Status > Conditions > Always active, and see if that works.

  13. Hi, so I imported the ui’s you have on your website and everything is great, EXCEPT for some reason on the party and raid ui’s I cannot get certain HoTs to show. The default did not include Enveloping Mist and Essence Font, and so when I use those it does not show on the raid frames. I tried adding them through the filters in elvui under buff indicators and set the settings to the same as for renewing mist, but it still does not show the HoTs on the raid frames.

    1. The elvui profiles are outdated since 7.0 (which means they’re tuned for the old spells) and I had the time yet to update them with everything’s that’s going on. But if you want to update the buff indicators go to /ec > Filters and select “Buff indicator” in the filter menu and then add the spells you want and remove the ones you don’t need. I’ll get around to an update someday, but it’s not highest on my priority list right now. But hope this helps :)

  14. Hey,
    This is amazing stuff, and I very much appreciate the work you put into all of this. However I have a quick question: Is Elvui needed to get these to work? I’ve added all the artwork and imported a couple/few of the weakaura’s you’d created, and while in the weakaura addon, I can see the artwork show for the ones I’ve imported, however, after closing the addon, I don’t see them anymore. I’ve logged in and out, reloaded ui, etc.
    Any idea’s? I’m sure I’ve borked something somewhere lol.

  15. Hello Ashleah,

    I’ve imported your settings, but I’m having a problem with the WeakAura that shows the Announcement Auras.

    Supposedly it should work with the Monk Custom Art Pack III, but that pack doesn’t contain the arts for the spells, only contains the circle (4 different ring textures). Browsed the rest of packs, and didn’t had those spell arts.

    How can I fix that?

    Regards

      1. The icons is a separate download, you can find the link to the Icon Package just above the export string to the announcement auras.
        If you see an invalid tag it means you haven’t installed the Elvui extension addons I recommended (Absorb tags & color tags). Download these and it’ll fix itself :)

  16. I love your art, its fantastic I have but one question, I’m using almost all of your pieces, just not the whole elvui code. I have things placed a little differently. NBD. My question is how do I change just the unit frame textures? I cant seem to find that anywhere. Thanks for all the amazing work.

    1. Great that you like the art :) The texture art files (in the texture package) need to be installed with the addon SharedMedia. If you install them, they should pop up in all the major addons that are connected to sharedmedia, (DBM, Elvui, Skada, etc etc) in their own menus. In elvui for example, you find the list of textures in /ec > Unit Frames.

  17. Your art is amazing! Thank you for sharing! :) However, I did run into a problem with the Mistweaver announcement ring. Majority of the spells seem to pop up when they are ready; however, I notice some of the spells do not. The two I noticed were Refreshing Jade Wind and Essence Font. Everything else seems to work just fine except for those two. Any solutions?

  18. Hi, I have been using your UI/WA since before Legion and after legion. I quit for a bit come back and for some reason, all of the icons I have except the new ones for spells ready and the new cups ones are not working they show but don’t light up. I tried removing and reuploading the wa strings to see if they just needed to be updated but still the same thing… everything is still the same and I followed directions exactly. even went through the troubleshooting guide and nothing.. my chat still works and so do other pretty looking features but those aren’t. I can’t figure it out.

    1. Alrighty, let’s try to figure out what the problem is. Can you describe what you mean with that they ‘don’t light up’? Do you mean glow effects or just in general not showing? Send a pic if something looks weird

  19. Sorry to ask but I seem to be having a problem with my frames, It does not show percentages or anything but instead shows the words “[classcolor]”. Any idea on how to fix this?

    1. Hello there,
      Depending on what you want to see on your unitframes, you must go into their separate option tabs in Elvui.
      For example, on my player frame in the health-tab I have [healthcolor][health:current-percent] which will show my total health and also if I lose hp and what % my hp is at.
      On the raidframes I’ve removed all text from the health and power tabs and only keep the text in the name tab, which looks like this [namecolor][name:short]

      It’s a bit tricky to explain, but depending on which tab on which unitframe, you will get different results. I think you need to find which tab has the [classcolor] in it and remove that piece of text.
      Hope this helps a little! Best of luck :)

  20. Hey , really like the work you do here enjoying it alot.
    Just switched to elvui to try it out .
    After importing you WW ui my character frame shows the text ¨class color¨instead of my health and resource . (the same for target frames and so on )

    Any way to fix this , been trying to fix this but can’t seem to find the problem.

    Keep it up

    1. Hello and thank you for your kind words!

      The reason you see the text “class color” is because the addon elvui color tags is outdated. So to fix this, just change the [classcolor] tag to [healthcolor] instead and it should resolve the issue.
      Hope this helps!

  21. Hello have this problem, seems i cant find the Icons for the Texture Auras Mistweaver Announcement Ring “Spells Ready”, have it downloaded, and its up to run, can see my ring but everything inside it is green squares.
    Interface\Addons\MistyTeahouse\MonkPRO\”Round-RenewingMist”
    Where do i find the textures for Round-[spells]?
    Everything else is working only need that single texture for my spells to show in the ring announcement.

      1. Haha thanks alot, it realy helped out.
        Gues i didnt saw that section in the green box.

        Thanks for the information, and keep up the good work realy like it.

  22. Hey i have bought the ZenUI but my problem is if i follow the instructions then on WA it shows me it loaded but nothing changes on my UI ( i have no green ■ showing up )
    Idk what i maybe do wrong or missed to install to use ur UI.
    can call me via mail or Ingame
    leftfordead95@web.de
    CrytekRanger#2271 ( battle.net )

    Ty for ur time

  23. Hi, thanks so much for producing such beautiful UI’s! I recently bought the Druid UI package and I’m also trying to use the resto artwork while playing on my priest. I have it so it appears, the chat backgrounds etc, however they automatically turn to the feral pink version of the artwork. I was wondering how I could get it so all the artwork remains in the ‘Resto’ form while using it on my priest?

    Thank you!

    1. If you open up the weakaura menu and go to the aura group you want to change (Druid Chat, for example). Open up the group and select the resto version. If you then go to the ‘Load’ tab, you can change which class and spec it appears for. Hope this helps :)

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.